Services are being upgraded as they are brought back online. So while some services are restored, others may be offline a little longer.
Posted Apr 04, 2026 - 08:45 CDT
Identified
We have had a power failure on the main server site due to weather conditions and old power hardware. We have migrated to another circuit and services should be restored shortly.
Posted Apr 04, 2026 - 08:22 CDT
This incident affected: Media Services (Media - Yellow, Media Services - Purple, Requests System), OWCOL (OWCOL Blog, OWCOL Store), and IIU Hostit, IIU Labs, IIU Docs, IIU Keys, IIU Files, IIU Help.